Skip to content Skip to sidebar Skip to footer

DDNS, Solusi IP Public Dynamic



Apabila Anda memasang CCTV dirumah atau di kantor, atau Server yang menjalankan service mail server, Web server maupun service lainnya, kemudian Anda ingin supaya CCTV dan layanan-layanan server tersebut bisa diakses melalui internet maka Anda harus memiliki akses internet dengan IP Public (termasuk juga sebuah router). Jadi, setiap kali ada orang yang ingin mengakses CCTV maupun server tersebut dari internet, maka orang tersebut harus menggunakan alamat IP Public yang Anda milki, perhatikan gambar dibawah ini
Remote host
Ilustrasi Akses host dengan IP Public
Dari gambar diatas, seorang client ingin mengakses server dan sebuah kamera CCTV melalui internet, terlihat bahwa server dan CCTV tersebut menggunakan IP Private 192.168.0.0/24, supaya komputer client bisa menjangkau server dan CCTV tersebut maka komputer client harus menggunakan IP Public dari komputer server dan CCTV nya yaitu 36.0.0.2. Untuk mendapatkan IP Public ini, kita harus berlangganan internet dari ISP (Internet Service Provider) yang ada.
Namun ada permasalahan yang mungkin terjadi dalam menggunakan IP Public ini, yaitu ISP memberikan IP Public Dynamic pada pelanggannya. Jadi, IP Public yang akan didapatkan oleh klient tersebut akan berubah-ubah, dan tidak static (tetap). Tentunya setiap kali ada perubahan pada IP Public yang didapatkan oleh klient, maka otomatis setiap orang yang ingin menghubungi server atau CCTV pada tempatnya harus mengetahui berapa IP Public yang baru, tentu saja ini akan sangat merepotkan. Berbeda halnya jika menggunakan IP Public yang static, permasalahan ini tidak akan terjadi.
Untuk mengatasi permasalahan IP Public Dynamic yang seperti ini maka bisa menggunakan DDNS (Dynamic Domain Name System). Dengan DDNS, klient hanya perlu menghafal apa nama DNS server kita, misalkan dnsrumahku.com atau selainnya tanpa perlu mengetahui berapa IP Public yang kita miliki (baik itu IP Dynamic ataupun Static) setiap kali ingin terkoneksi dengan server yang kita miliki. Kurang lebih ilustrasinya seperti tampak pada gambar dibawah ini.
Remote host dengan DDNS
Penggunaan DDNS
            Seperti gambar diatas, saat seseorang ingin mengakses server yang kita miliki, mereka hanya perlu menghafal nama DNS tersebut (dnsku.com, seperti tampak pada gambar). Maka DDNS Serverlah yang akan meneruskan koneksi tersebut ke IP Public yang kita miliki. Walaupun IP Public kita berubah-ubah setiap saat, DDNS Server akan mendeteksi perubahan tersebut kemudian memperbarui informasi IP Public yang kita miliki dengan nama DNS. Ada banyak penyedia jasa DDNS yang bisa digunakan seperti no-ip.com, bahkan bisa juga menggunaan IP Cloud yang dimiliki oleh router mikrotik. Oleh karena itu pada tulisan kali ini kita akan membahas cara menggunakan DDNS ini untuk mengatasi IP Public Dynamic menggukan No-IP dan juga IP Cloud Mikrotik.

IP Cloud Mikrotik

Solusi pertama dan yang paling mudah yang bisa Anda gunakan adalah memanfaatkan IP Cloud yang dimilki oleh router mikrotik. Namun, perlu diperhatikan jika ingin menggunakan IP Cloud mikrotik ini versi router OS mikrotik anda minilam pada versi 6.14 dan tentunya memiliki perangkat router mikrotik. Dengan IP Cloud ini, anda akan diberikan sebuah DNS oleh mikrotik.com yang siap Anda gunakan. Cara mengaktifkan IP Cloud ini cukup mudah, pada terminal mikrotik cukup ketikkan perintah :
            ip cloud set ddns-enabled=yes update-time=yes       
Anda juga bisa melakukan konfigurasi IP Cloud ini melalui winbox, dari menu IP → Cloud, kemudian centang pada bagian DDNS Enabled dan Update Time.
IP Cloud Mikrotik
IP Cloud Mikrotik
Sesaat setelah di aktifkan IP Cloud ini, maka secara otomatis router Mikrotik akan menampilkan berapa IP Public yang didaptkan, serta nama DNS dari mikrotik.com yang telah disediakan, perhatikan pada keterangan Public Address dan DNS Name pada gambar diatas. Sekarang Anda bisa melakukan remote ke router mikrotik tersebut, atau mengakses CCTV, Web Server  dan lain sebagainya melalui jaringan internet dengan menggunakan nama DNS yang telah disediakan.
Jika diperhatikan, nama DNS nya susah sekali untuk dihafalkan tidak seperti DNS-DNS yang selama ini kita sering kenal misalkan seperti sekolahku.com dan lain-lain. Nama DNS ini terlihat aneh, ini karena pembuatan nama DNS pada mikrotik.com ini menggunakan format [Serial Number Routerboard].sn.mynetname.net.  Oleh karena menggunakan Serial Number, maka IP Cloud mikrotik ini belum bisa digunakan untuk produk mikrotik x86. Jadi sekali lagi Anda harus memiliki perangkat router board untuk bisa menikmati layanan IP Cloud Mikrotik !!

No-IP

Solusi kedua yang bisa anda coba ialah dengan menggunakan layanan DDNS yang banyak tersedia di internet, contohnya NO-IP. Sama seperti router mikrotik yang sebelumnya kita bahas, NO-IP juga akan memberikan Anda sebuah nama DNS yang bisa anda gunakan untuk mengakses sumberdaya jaringan ditempat Anda melalui internet, namun No-IP tidak lah gratis !!. Tapi tenang, walaupun tidak gratis, NO-IP memberikan anda mencoba produknya free selama 1 bulan. Ok, untuk menggunakan No-IP ini, pertama-tama kita harus melakukan registrasi account pada server no-ip melalui situs resminya di https://www.noip.com/.
Website No-IP
Website No-IP
Untuk memulai registrasi account, klik menu Sign Up pada pojok kanan bagian atas, kemudian isikan data-data untuk melengkapi proses registrasi seperti alamat email serta password yang akan digunakan untuk login pada server no-ip, terakhir klik klik Free Sign Up.
Registrasi Account No-IP
Registrasi Account No-IP
Apabila proses registrasi berhasil maka akan ditampilkan notifikasi seperti tampak pada gambar dibawah ini, dan Anda harus membuka email yang anda gunakan untuk mendaftar no-ip untuk melengkapi proses registrasi.
Account No-IP Berhasil dibuat
Account No-IP Berhasil dibuat
Setelah proses registrasi berhasil, maka cobalah untuk login ke account no-ip tersebut, jika berhasil login maka pada bagian pojok kiri halaman home page no-ip akan terdapat keterangan login id email anda.
Login account No-IP
Login account No-IP
Langkah selanjutnya yang harus dilakukan adalah membuat nama DNS, klik tulisan Manage DNS yang terdapat pada kotak warna merah pada gambar diatas. Kemudian pada pilihan My Service klik Create Host Name. Sekarang kita bisa mengisikan nama DNS sekehendak kita, namun karna menggunakan account yang free, maka pada bagian belakan nama DNS yang akan kita buat akan terdapat keterangan nama domain gratisan dari No-IP yaitu ddns.net serta masih banyak nama lain lagi yang bisa kita pilih. Jika semua data yang dibutuhkan telah selesai kita isi, klik Add Hostname.
Membuat host name baru
Membuat host name baru
Setelah hostname berhasil di buat, maka pada menu Manage DNS Record akan ditampilkan hostname tersebut beserta informasi IP Address nya. Kita masih bisa membuat 2 hostname tambahan lagi jika dibutuhkan. Namun karena kita hanya memiliki 1 IP Public, maka kita cukup membuat 1 hostname saja.
Daftar hostname yang telah dibuat
Daftar hostname yang telah dibuat
Setelah nama DNS berhasil kita daftarkan, maka langkah selanjutnya adalah melakukan download dan instalasi Dynamic Update Cleint (DUC) pada komputer atau laptop kita. Perlu diketahui, komputer atau laptop yang akan kita installkan program DUC ini harus berada pada satu jaringan dengan lokasi IP Public Dynamic yang akan dipasangkan DDNS nya.
DUC untuk OS Windows
DUC untuk OS Windows

Komputer dengan DUC Software
Komputer dengan DUC Software
Fungsi dari DUC ini adalah akan melakukan pengecekan secara berkala terhadap perubahan IP Address Public, jika terdapat perubahan maka secara otomatis akan melakukan update perubahan IP Address baru pada hostname yang telah kita daftarkan. Adapun komputer tempat terinstall nya program DUC ini harus selalu dalam kondisi hidup dan terhubung dengan internet, karena jika terjadi perubahan IP Address dan komptuer nya dalam kondisi Off maka perubahan IP Address tersebut tidak akan terdeteksi.  Silahkan download DUC berdasarkan system operasi yang anda gunakan, dan lakukan proses instalasi mengikuti petunjuk instalasi DUC nya.
Setelah proses instalasi DUC berhasil, maka kita harus memasukkan username dan password account No-IP yang telah kita daftarkan.
Login No-IP melalui DUC
Login No-IP melalui DUC
Setelah berhasil login, maka klik tombol menu Edit Hosts, pilih nama DMS yang telah kita dafarkan kemudian centang pada bagian Require Password to modify host dan isikan password yang kita kehendaki. Password ini akan berguna untuk membatasi jika ada orang lain yang mau merubah konfigurasi DUC kita ini.
Konfigurasi DUC
Konfigurasi DUC
Setelah berhasil memilih host, maka tampilan dari DUC ini akan tampak seperti pada gambar dibawah ini.
DUC Berhasil dikonfigurasi
DUC Berhasil dikonfigurasi
Ada satu lagi konfigurasi yang perlu dilakukan, yaitu melakukan konfigurasi supaya DUC ini otomatis berjalan saat komputer dihidupkan. Dari menu File klik Preference kemudian centang pada bagian Enable a system service…
Konfigurasi service DUC
Konfigurasi service DUC

Kombinasi No-IP dan Router Mikrotik

            Router mikrotik memiliki fitur IP Cloud yang berfungsi layaknya DDNS, begitupun dengan No-IP. Namun, kita bisa melakukan kombinasi antara router mikrotik dengan No-IP ini. Cara kerjanya adalah, kita akan membuat script yang akan di tanamkan pada router mikrotik, pada script tersebut berisikan informasi dari account No-IP yang telah kita buat sebelumnya. Jadi, kita tidak perlu melakukan instalasi DUC pada komputer tertentu. Script mikrotik ini saya dapatkan dari situs mikrotik Indonesia, pada link ini.

# No-IP automatic Dynamic DNS update
#--------------- Change Values in this section to match your setup ------------------
# No-IP User account info
:local noipuser "account_no-ip"
:local noippass "password_no-ip"
# Set the hostname or label of network to be updated.
# Hostnames with spaces are unsupported. Replace the value in the quotations below with your host names.
# To specify multiple hosts, separate them with commas.
:local noiphost "alamat_host_no-IP"

# Change to the name of interface that gets the dynamic IP address
:local inetinterface "Interface_router_yang_terkoneksi_ke_internet"

#------------------------------------------------------------------------------------
# No more changes need

:global previousIP

:if ([/interface get $inetinterface value-name=running]) do={
# Get the current IP on the interface
   :local currentIP [/ip address get [find interface="$inetinterface" disabled=no] address]

# Strip the net mask off the IP address
   :for i from=( [:len $currentIP] - 1) to=0 do={
       :if ( [:pick $currentIP $i] = "/") do={
           :set currentIP [:pick $currentIP 0 $i]
       }
   }

   :if ($currentIP != $previousIP) do={
       :log info "No-IP: Current IP $currentIP is not equal to previous IP, update needed"
       :set previousIP $currentIP

# The update URL. Note the "3F" is hex for question mark (?). Required since ? is a special character in commands.
       :local url "http://dynupdate.no-ip.com/nic/update3Fmyip=$currentIP"
       :local noiphostarray
       :set noiphostarray [:toarray $noiphost]
       :foreach host in=$noiphostarray do={
           :log info "No-IP: Sending update for $host"
           /tool fetch url=($url . "&hostname=$host") user=$noipuser password=$noippass mode=http dst-path=("no-ip_ddns_update-" . $host . ".txt")
           :log info "No-IP: Host $host updated on No-IP with IP $currentIP"
       }
   }  else={
       :log info "No-IP: Previous IP $previousIP is equal to current IP, no update needed"
   }
} else={
   :log info "No-IP: $inetinterface is not currently running, so therefore will not update."
}

Pada script tersebut ada beberapa bagian yang perlu diubah sesuai dengan data No-IP yang anda miliki, yaitu pada bagian :
local noipuser "account_no-ip", pada bagian account_no_ip harus diisi dengan user ID/alamat email yang digunakan untuk login ke no-ip.com
local noippass "password_no-ip", pada bagian password_no_ip harus diisi dengan password account no-ip anda.
local noiphost "alamat_host_no-IP", pada bagian alamat_hos_no_ip harus diisi dengan nama hostname yang didaftarkan pada server no-ip.
local inetinterface "Interface_router_yang_terkoneksi_ke_internet", pada bagian interface_router harus diisi dengan nama interface pada router mikrotik yang tekoneksi langsung ke internet.
            Setelah semua data no-ip yang dibutuhkan dimasukkan kedalam script tersebut, selanjutnya pada router mikrotik kita buat script baru melalui menu System → Scripts → Add dan copy script tersebut sehingga tampak seperti gambar dibawah ini.
Membuat Script pada Mikrotik
Membuat Script pada Mikrotik
Implementasi Script dengan No-IP
Implementasi Script dengan No-IP
            Setelah itu kita buat schedule baru yang akan menjalankan script tersebut melalui menu System → Scheduler → Add, kemudian lakukan konfigurasi scheduler seperti tampak pada gambar dibawah ini.
Menjalankan Script dengan Schedule
Menjalankan Script dengan Schedule
            Jika konfigurasi yang dibuat berhasil, maka seharusnya pada log mikrotik akan ditampilkan setiap perubahan IP mauapun tidak adanya perubahan IP Address pada router anda.
Log script
Log script
            Nah, itu beberapa solusi yang bisa anda lakukan apabila IP Publik yang anda miliki adalah IP dynamic. Silahkan dicoba satu-persatu, semoga bermanfaat dan terima kasih sudah berkunjung.

Post a Comment for "DDNS, Solusi IP Public Dynamic"